Home Wiki Blog Forum GEXF.net

Gephi forums

Community support

Help Installing Gephi

Problems with getting it running

Help Installing Gephi

Postby ismasters » 27 Apr 2013 16:53

Dear all,

I'm a new user of Gephi. I was able to get it installed without a problem on my work PC, but am struggling to install it on my personal Mac. I've downloaded the application, and when I click on it in the disk image, it works exactly as expected. The interface loads, I'm able to open my files, etc.

However, when I drag it to my application folder (or anywhere else on my computer), the application won't load. The window opens, it reads "Opening Main Window..." for a few moments. Here's a screenshot of what I get. Nothing shows up under File, Workspace, View, Tools, or Window, although I do have options under Plugins. The little red minus sign in the bottom right corner reads "Unexpected Exception: java.lang.NullPointerException." It also appears initially when I open Gephi off the disk image, then goes away shortly.

I've tried making sure that I have Java 6 (I do and it seems to be activated, confirmed with Terminal). I've tried restarting. I've tried deleting it and my directory, re-downloading and reinstalling. Any suggestions on how to proceed would be greatly appreciated.
ismasters
 
Posts: 1
Joined: 27 Apr 2013 16:39

Re: Help Installing Gephi

Postby joshnankivel » 27 Jul 2013 00:07

Same problem here.

First it wouldn't launch at all, then I installed Java.
It still wouldn't launch, I tried to run 'Java VisualVM' just for the heck of it. Then it prompted me to install the JRE, which I did.
Now Gephi launches, but sits at the main window (unloaded, gray background) and menu items on my Mac are unloaded.
joshnankivel
 
Posts: 1
Joined: 27 Jul 2013 00:04

Re: Help Installing Gephi

Postby Cartowsky » 09 Aug 2013 18:09

+1

I had the same exact situation on mac (OS X Mountain Lion, 64bit)
I should add that at first trial few days ago (after having performed the Java install) it worked.
Then i deleted it and re-installed it today, but nothing. same grey workspace and empty menus.
Here's the error it gave:
Code: Select all
java.lang.NullPointerException
   at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.getSuperIdentity(AutoupdateSettings.java:435)
   at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.generateIdentity(AutoupdateSettings.java:136)
   at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.signOn(AutoupdateCheckScheduler.java:110)
   at org.netbeans.modules.autoupdate.ui.actions.Installer.restored(Installer.java:63)
   at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:469)
[catch] at org.netbeans.core.startup.NbInstaller.loadImpl(NbInstaller.java:392)
   at org.netbeans.core.startup.NbInstaller.access$000(NbInstaller.java:103)
   at org.netbeans.core.startup.NbInstaller$1.run(NbInstaller.java:344)
   at org.openide.filesystems.FileUtil$2.run(FileUtil.java:619)
   at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:127)
   at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:607)
   at org.openide.filesystems.FileUtil.runAtomicAction(FileUtil.java:603)
   at org.openide.filesystems.FileUtil.runAtomicAction(FileUtil.java:623)
   at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:341)
   at org.netbeans.ModuleManager.enable(ModuleManager.java:1179)
   at org.netbeans.ModuleManager.enable(ModuleManager.java:1002)
   at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
   at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
   at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:296)
   at org.netbeans.core.startup.Main.getModuleSystem(Main.java:169)
   at org.netbeans.core.startup.Main.start(Main.java:305)
   at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
   at java.lang.Thread.run(Thread.java:680)


BUT
after i deleted the old gephi folder in
/Users/YourUserName/Library/Application Support (beware of the space character)
everything went back to normal!
Hope this helps.
Cartowsky
 
Posts: 2
Joined: 02 Jul 2013 22:36

Re: Help Installing Gephi

Postby Niccolò Mineo » 21 Aug 2013 12:54

I only wanted to say THANK YOU to Cartowsky. This bug was driving me crazy.
Niccolò Mineo
 
Posts: 1
Joined: 21 Aug 2013 12:53

Re: Help Installing Gephi

Postby pajachiet » 13 Sep 2013 14:09

I had the same problem on Ubuntu, which drove me crazy.

A solution is to delete this hidden folder /home/NAME/.gephi/
pajachiet
 


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests