Home Wiki Blog Forum GEXF.net

Gephi forums

Community support

Gephi 64 bit won't start on Win 7 and Win 8.1 [SOLVED]

Problems with getting it running

Gephi 64 bit won't start on Win 7 and Win 8.1 [SOLVED]

Postby joyofdata » 19 Oct 2013 15:46

Hi!

I am using Gephi 0.8.2-beta on Windows 8.1 Pro 64bit with JRE 7 U45 64bit.

bin\gephi.exe launches successfully but bin\gephi64.exe will do "something" (this in-progress-cursor shows) and then simply nothing happens.

According to event manager gephi64.exe produces an "Application Error" which claims that gephi64.exe is defective and additionally mentions that module C:\WINDOWS\SYSTEM32\ntdll.dll is defective as well.

Because I plan to handle large graphs with Gephi (my notebook calls 32GB RAM its own for a reason) I would like to use the 64bit version.

Thanks in advance

Raffael
Last edited by joyofdata on 31 Oct 2013 17:42, edited 2 times in total.
joyofdata
 
Posts: 3
Joined: 19 Oct 2013 15:33
Location: Munich, Germany

Re: Gephi 64 bit won't start on Win 8.1

Postby francis_flavin » 21 Oct 2013 21:06

Thanks, Raffael, for the post. I don't have Windows 8.1 installed yet so I can't be of assistance.

Did you use Gephi with Windows 8 64-bit with JRE 64-bit successfully in the past? In other words, are you convinced this is solely a Windows 8.1 issue?

Thanks for posting this. Given the recent official release of Window 8.1, it was a timely post.

I'll let you know if I learn anything further.


Francis
francis_flavin
 
Posts: 55
Joined: 21 Jan 2012 19:34
Location: Washington, DC, USA

Re: Gephi 64 bit won't start on Win 8.1

Postby joyofdata » 23 Oct 2013 08:46

Hi Francis,

I tried to start Gephi 64bit now on a different machine:

Windows 7 Pro 64bit
JRE 7 U25 (Build 1.7.0_25-b17) 64bit

I observe the same symptoms: gephi.exe starts, gephi64.exe only seems to start.

Event manager message (translated from German):

Code: Select all
name of defective application: gephi64.exe, version: 0.0.0.0, time stamp: 0x4feb2035
name of defective module: ntdll.dll, version: 6.1.7601.18247, time stamp: 0x521eaf24
code of excpetion: 0xc0000026
offset of error: 0x00000000000cd7e8
ID of defective process: 0x2014
path of defective application: C:\Program Files (x86)\Gephi-0.8.2\bin\gephi64.exe
path of defective module: C:\Windows\SYSTEM32\ntdll.dll


I am not developing software on an OS level so this is rather a semi-blind guess; wouldn't the 64bit version have to use "C:\Windows\SysWOW64\ntdll.dll" instead?

Regards

Raffael
joyofdata
 
Posts: 3
Joined: 19 Oct 2013 15:33
Location: Munich, Germany

Re: Gephi 64 bit won't start on Win 7 and Win 8.1

Postby joyofdata » 31 Oct 2013 17:41

All I had to do was set the value of jdkhome in gephi.conf:

Code: Select all
jdkhome="C:\Program Files\Java\jre7"


The reason I didn't try this earlier was because I only have Java 64bit installed and the 32bit Gephi worked. But anyway - that did the trick. :!:
joyofdata
 
Posts: 3
Joined: 19 Oct 2013 15:33
Location: Munich, Germany

Re: Gephi 64 bit won't start on Win 7 and Win 8.1

Postby dataset » 03 Nov 2013 13:00

Hi all,

I am running Win 7, 32-bit and have downloaded the required gephi installation files and installed the s/w. I have not been able to launch Gephi (32-bit version). I searched around and found that I may have to change the conf file, I installed the latest JDK, JRE and changed the path of JDK in the conf file. I am still unable to use gephi. How do I change the home and Appname parameters on conf file? Here is my conf file now:

Thanks in advance, I am eager to use Gephi for some personal visualization experiments ! :)

Code: Select all
# ${HOME} will be replaced by user home directory according to platform
default_userdir="${HOME}/.${APPNAME}/0.8.2/dev"
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/0.8.2/dev"

# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="--branding gephi -J-Xms64m -J-Xmx512m -J-Xverify:none -J-Dsun.java2d.noddraw=true -J-Dsun.awt.noerasebackground=true -J-Dnetbeans.indexing.noFileRefresh=true -J-Dplugin.manager.check.interval=EVERY_DAY"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea

# default location of JDK/JRE, can be overridden by using --jdkhome <dir> switch
jdkhome="C:\Program Files\Java\jdk1.7.0_45"

# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)
#extra_clusters=
dataset
 
Posts: 1
Joined: 03 Nov 2013 12:54


Return to Installation

Who is online

Users browsing this forum: Google [Bot] and 0 guests